CentOS完全编译安装最新版LAMP


文章比较早,阿里云也发生了不少变化,当然系统一如既往的旧,推荐大家去阅读一些更新的文章。-2014.1.20

阿里云的centos源比较老,php,httpd,mysql都不怎么新,php竟然还是5.1.16版本,现在最新都5.4.7了,漏洞多不说,很多组件也不兼容,因此完全编译安装以下:

PHP 5.4.7

HTTPD  2.4.3

MySQL Community Server 5.5.28

1、安装httpd

首先安装必须的环境

下载所有安装包,包括apr,apr-util,httpd,pcre

解压pcre并安装 继续阅读CentOS完全编译安装最新版LAMP

CentOS/AWS编译安装LNMP环境


本文可看作AWS/CENTOS搭建LAMP环境的姊妹篇。

1、启用额外的库(参照racksapce,aws的默认ami库里面东西很全,基本上都可以yum到,可以忽略这部分)

centos5没有自带的nginx和php-fpm,因此从别的库拿来。导入RHEL EPEL

编辑remi的repo

如下:

后来我发现这样子的话安装的nginx版本太古老,安装remi库用于安装phpfpm,另外用nginx.repo安装最新版的nginx,方法

编辑

如下

2、安装

安装完之后

继续阅读CentOS/AWS编译安装LNMP环境